Sign in to follow this  
Followers 0

English macbook not working with German wi-fi

45 posts in this topic

Hi folks, I was so happy to discover this site as I have just moved into Germany (Hamburg) from the UK but haven't had much time to brush up on my German language skills.

 

I did some searching before posting this, and appreciate there are several similar topics. I haven't managed to get anywhere yet though so I'm hoping one of you kind people might be able to help : )

 

I have moved in with a family who have wi-fi working on all of their laptops. My Macbook however seems unable to connect to the Internet via their Speedport W 501V router. The really infuriating thing is that yesterday for about one hour I managed to connect (after renewing DHCP lease a few times it randomly worked eventually). Although I had no idea why, I thought the problem was solved. After waking the laptop this morning though I have been unable to connect wirelessly. I can connect when plugged into the router, which is good news but not amazingly convenient. Mac filtering is off, security is a WEP password which I have. I have full access to the router and have tried unplugging and resetting via the software, but this seems to make no difference.

 

Also my Dell laptop and iPhone won't connect. I'm not sure if this is related or not. My main concern is the Macbook as I need it for work.

 

Have I missed something obvious?

 

Thanks for reading!

0

Share this post


Link to post
Share on other sites

If it works with cable, maybe you are just on the border of the routers range?

 

Try taking it close to the router and re-try. If it works then for a while, see if there are any option for turning up the power on the router in the settings

 

I had similar problems in a hotel once, which would give access, and drop out at certain times of the day ( do not really know why, atmospherics change during the day ) and would connect near the router.

 

Have fun

0

Share this post


Link to post
Share on other sites

Firstly, the fact that the router is 'German' and your Macbook is from the UK is nothing to do with with your problem, secondly, it is very unlikely that you will be able to increase the broadcast strength of the Wifi on this model.

Go to the webadmin form for the router (type in this IP address in to your browser: http://192.168.2.1) and check that the subnet mask number is the same on the router and on your computer.

You might also want to check that the firmware on the router is up to date.

0

Share this post


Link to post
Share on other sites

I had he same issues with my mac, and my husband had to change some settings in the router as it was only accessable to pcs, so he did something called a mac filter, and now it works.

 

I can ask him when he gets home, I think you have the same issue.

0

Share this post


Link to post
Share on other sites

 

it was only accessable to pcs, so he did something called a mac filter

 

MAC filtering is to allow access based on the client's MAC Address, not based on whether or not the client is a Mac or PC.

 

Edit: but yes, MAC filtering would prevent access, if it's enabled and the client machine's MAC address is not in the list.

0

Share this post


Link to post
Share on other sites

yeah..

 

mac filtering is probaly switched on..

 

I wish my Laptop had TTfiltering ... :D

0

Share this post


Link to post
Share on other sites

Yeah, it has nothing to do with UK or German anything.

 

1st- how strong is the signal?

2nd- do you get an IP address?

3rd- if yes to #2, can you ping the router?

4th- if yes to #3, can you ping www.google.com? This will answer two things, 1- if DNS is working, because it will translate the name google.com to the IP address, and if you can ping it, you know that you are connected to the internet.

 

Also, is anyone else connected to it? Does it work for them?

0

Share this post


Link to post
Share on other sites

You must approach your German router confidently. Shine a powerful light onto it. Look it in the LEDs. Whack your leg with your leather gloves. Smile menacingly and then in a sickly sweet voice inform it, "Ve haff vays of making you talk!" If it fails to cooperate, beat it severely shouting "Schweinehund!"

5

Share this post


Link to post
Share on other sites

That is why I do not attempt to comprehend computers and cry for mrserenajean1 anytime something goes wrong.

 

But after that it worked. Maybe the op can try that if you guys can explain it.

0

Share this post


Link to post
Share on other sites

Well, the OP said in the first post that MAC filtering is turned off...In this case it means MAC Address filtering, not Apple Mac filtering :) So, it isnt the issue, I'm pretty sure.

 

I think Mr Nosey is on to something though...it IS a German router, there might be some paperwork or something that is missing!

1

Share this post


Link to post
Share on other sites

 

I think Mr Nosey is on to something though...it IS a German router, there might be some paperwork or something that is missing!

 

@ the OP, hast du schön Gemeldet?

0

Share this post


Link to post
Share on other sites

Hey guys, thanks for all the replies! MAC (nothing to do with Apple) filtering is turned off. The router actually lists all MAC addresses and the Macbook is displayed (although it is listed under the name "no name"), so it is connected to the network. The wireless signal is very strong, and weakens as expected when the laptop is further away.

 

When I renew the DHCP licence in TCP/IP Settings it thinks for a few seconds, then displays the same address that was already there. If I enter IPv4/Subnet/Router details manually, the green "Connected" light graphic appears next to Airport but when I open Chrome/Safari I get "This webpage is not available". When I use auto DHCP the light is yellow and it says "AirPort has the self-assigned IP address 169.254.91.250 and will not be able to connect to the Internet." The IP address does not change when I click "Renew DHCP Lease". DHCP is turned on in the router's Konfigurationsprogramm.

 

If I update the router firmware will it retain all the login info or will I have to start again? I don't want to break the Internet for everyone else!

 

Thanks : )

0

Share this post


Link to post
Share on other sites

Ok, I have had the same problem with Airport on my MacBook Pro, I resolved it by deleting 'Airport' in Network Preferences, hit 'Apply', then click on '+' at the bottom of the list of services and re-add 'Airport'.

As soon as you get a connection again, check Software Update, i'm pretty sure this problem was resolved in an update a while ago.

 

(Ps: I can't see why updating the firmware on the router would delete passwords etc..)

0

Share this post


Link to post
Share on other sites

DrinkYourMilkshake: I'd stay well away from resetting the router to factory state and/or updating any firmware, you'll most likely end up buggering the router for everyone else as well.

 

Have you tried turning the router off, unplugging from the mains for 60 seconds and booting it all up again? (Again, I would ask the family if it's ok to do)... as strange as it sounds routers when left on for weeks/months tend to get cranky with new DHCP leases sometimes (the old BT home hub I had used to have it's DNS cache fill up after weeks so it'd need constant power-cycling).

 

If you do decide to turn off the router, I would suggest that you delete the access point on your mac so it re-prompts you to select the access point/type in the password. At least this way from your computer's perspective it's connecting to it afresh.

0

Share this post


Link to post
Share on other sites

Are you sure you are allowing your router to assign you an IP? Make sure "using DHCP" is selected for Airport in Network preferences.]

0

Share this post


Link to post
Share on other sites

Also, how many addresses is DHCP allowed to give out?

 

I'm more concerned that the Dell laptop doesnt get an IP address as well...Macs can be finicky, but the Dell should have no problem.

0

Share this post


Link to post
Share on other sites

Is it an integrated Router/modem? If there is a separate modem, disconnect the power from that as well as the router, wait for 30 seconds, reconnect the modem, then the router.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0